Print Page | Close Window

Need information on version compatibility

Printed From: Debenu Quick PDF Library - PDF SDK Community Forum
Category: For Users of the Library
Forum Name: I need help - I can help
Forum Description: Problems and solutions while programming with the Debenu Quick PDF Library and Debenu PDF Viewer SDK
URL: http://www.quickpdf.org/forum/forum_posts.asp?TID=3951
Printed Date: 15 Oct 21 at 9:18PM
Software Version: Web Wiz Forums 11.01 - http://www.webwizforums.com


Topic: Need information on version compatibility
Posted By: Mvel
Subject: Need information on version compatibility
Date Posted: 09 Sep 21 at 7:53AM
Delphi vs Quick PDF library compatibility

Recently we had upgraded from Delphi XE2 to Delphi 10.3, and also upgraded the Quick PDF library from 14.11 to 17.11.

Now we are not able to perform any of the Quick PDF related functionalities as it was earlier, we are suspecting it is something related to compatibility.

We are looking for Delphi vs Quick PDF library compatibility related information, it would be helpful if you guys help us on this, thanks in advance.



Replies:
Posted By: tfrost
Date Posted: 09 Sep 21 at 10:43AM
First, welcome to this user forum!

We started using Quick PDF with version 7 and Delphi 2010.  I do not recall needing to make any significant changes to my source code because of backward compatibility issues between library versions, although of course we have changed many other things over the years and added more ways in which the library has been used.  

I suggest checking that none of the older files are visible in your new development environment.  And also posting full details of specific compiler/building errors or function error returns that you see, so that we have some idea of what the actual problem might be.




Posted By: Mvel
Date Posted: 09 Sep 21 at 2:17PM
tfrost, thanks for sharing your valuable insights.

It seems our application is referring 14.11's license key, instead of 17.11, we have replaced it with the recent one. Thanks again :)


Posted By: Ingo
Date Posted: 09 Sep 21 at 7:38PM
Hi Mvel,


Rio (Delphi 10.3) ist supported from QuickPDF 16.12 onwards.

Here a post from a user who couldn't find the Rio-related stuff:

The latest release, 16.12, says it has support for Delphi 10.3 RIO.
https://www.debenu.com/products/development/debenu-pdf-library/updates/
However, the licensed download has no ZIP files for the RIO version. Will this be rectified soon?

This is what Albano (from publisher support) answered:

Not sure if this issue is still ongoing, but the 10.3 Rio links are available in the 16.12 package Delphi folder.
Standard folder location:
C:\Program Files (x86)\Debenu\PDF Library 16\Delphi\DebenuPDFLibrary1612Delphi10.3RioWin32

So i think your issue is only a "how to find" or an installation-prob?


Cheers and welcome here,
Ingo



-------------
Cheers,
Ingo



Posted By: Mvel
Date Posted: 13 Sep 21 at 7:26AM
Hi Ingo,

I appreciated the detailed information you sent through. As you mentioned, it's an installation related issue, by mistake we had used the license key of version 14.11 instead of 17.11.

We have been communicating with Quick PDF support team to procure the corresponding license key, thanks again :)



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.01 - http://www.webwizforums.com
Copyright ©2001-2014 Web Wiz Ltd. - http://www.webwiz.co.uk